The RC1 live CD does not install grub successfully automatically or manually

Andrew DeMarsh andrew at andrewdemarsh.ca
Wed Dec 10 15:26:22 EST 2014


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Good news and bad news, the live CD doesn't install grub correctly but
this is not due to tanglu's grub package. following the below steps
should allow you to install grub on the system via the live CD:
$ sudo mkdir /media/tanglu
$ sudo lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0    80G  0 disk
├─sda1   8:1    0   5.8G  0 part [SWAP]
├─sda2   8:2    0  36.7G  0 part
└─sda3   8:3    0  37.6G  0 part
sr0     11:0    1   1.1G  0 rom  /cdrom
loop0    7:0    0     1G  1 loop /rofs

$ sudo mount /dev/sda2 /media/tanglu
$ sudo mount --bind /dev /media/tanglu/dev
$ sudo mount --bind /dev/pts /media/tanglu/dev/pts
$ sudo mount --bind /proc /media/tanglu/proc
$ sudo mount --bind /sys /media/tanglu/sys
$ sudo chroot /media/tanglu
# grub-mkconfig -o /boot/grub/grub.cfg

Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when
GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found background image: /usr/share/images/grub/grub.png
Found linux image: /boot/vmlinuz-3.16-3-amd64
Found initrd image: /boot/initrd.img-3.16-3-amd64
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
done

# grub-install /dev/sda

Installing for i386-pc platform.
Installation finished. No error reported.
root at ubuntu:/# grub-install --recheck /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.

# exit

exit

$ sudo umount /media/tanglu/dev/pts /media/tanglu/dev
/media/tanglu/proc /media/tanglu/sys /media/tanglu

I'm still not sure what is causing the live CD to mess this up. I'll
investigate further tonight.


On 14-12-10 03:01 PM, Andrew DeMarsh wrote:
> When Installing the live CD in a VM the Grub Install finishes
> reports it installed but upon boot has not installed at all. When
> booting back into the live environment and mounting the filesystem
> and chrooting into it to reinstall grub it seems to finish
> installing correctly but fails upon reboot as can be seen  at the
> imgur link below http://i.imgur.com/l6YDzpt.png Will report back if
> using another live CD to install grub works so grub can be
> investigated. _______________________________________________ 
> Tanglu-devel mailing list Tanglu-devel at lists.tanglu.org 
> http://lists.tanglu.org/mailman/listinfo/tanglu-devel
> 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJUiKxjAAoJENSYOsQdm821LKMP/19YOH8YQBPEWqhlFxzRCl5i
V+P97lG9wOdNM0gGiGOJcpnI9cMktHwZkX4gg2i3r1NDk0GwXhfeaXBHxqM9oao3
RWydeJWVICyEIbwTnduEIpWv2ArOvhIXDF86vxkOFSbYCeNWZXF3ad1NwRWEsp5C
/ZhArj8WfWpq+2/rnPkO1Hl0TxQ6QMrHRIZYjUqsJ9/4Q48ODmbiArP0xI2QaQi5
WsEEpzNG/XX7XdasoJlG9tPpdj/QxVBvuhAU/M7HalBZUFwo7RrlnpZa5t6OggLt
sXVgF1Dx5p8JI0D5rOeIzFjxwI14ZwC5giGr6DE7BCDaRKm0FXothIySxACAd0Ti
MA0bt+m/Adv4gWaG7JJGLTrVcdoKdg1+JRgRFE+C37xWGydOfmBKYVG/U4tqkcbS
ehJICJWXNnuFa9Xay+Xoe2c1zCJBuXvLJbmshVUMZ1nUOP9s4uibJbf4259J5qdl
NexicdX8bFassMmgPXIRBZf6+uyiJVYaaaWnkfWgvHbxjsHvB9ZAZFXM4T+BOEEt
sSRq6PmDn/eOaOGY2pGwQWqOXmsMTxens6FCdpXO64eXfnVhNomwV5Ji/otZH3N4
c0CcVBRXLsrl32GNZHtLnjCzkHfa2YUox5i/0J45NQ7WCvbCbkN/zUa8QVSSNnQl
+XE1U5q4pVBY6fBvGkUb
=Sh/c
-----END PGP SIGNATURE-----


More information about the Tanglu-devel mailing list