GNOME lovers needed for live-cd help!

Matthias Klumpp matthias at tenstral.net
Tue Jan 14 10:40:30 EST 2014


2014/1/14 Thomas Funk <t.funk at web.de>:
> Hi,
>
>> From: Matthias Klumpp <matthias at tenstral.net>
>> Date: 2014/1/13
>> Subject: GNOME lovers needed for live-cd help!
>> To: Tanglu development list <tanglu-devel at lists.tanglu.org>
>>
>>
>> Hi!
>> This is just an information for people liking GNOME: While the KDE
>> live-cd works fine, the GNOME-CD still has issues, mainly that GDM3 is
>> unable to start the GNOME session. If the GNOME-Shell is launched
>> manually, it is functional.
>> So, if you have some GNOME knowledge and would like to fix this,
>> please get in contact. Otherwise, we won't be able to fix this issue
>> and won't provide GNOME live-cds at release time.
>> Regards,
>>     Matthias
> I've tested it and the problem could be the gnome-session-daemon.
>
> It ends up in a segfault:
> [....] gnome-settings-daemon [...]: segfault at 0 ip (null) sp bf9f5bbc error 4 in gnome-settings-daemon[8048000+8000]
Hmm, we need debug symbols to properly test this (and run it with gdb
- which might already be helpful even without debug symbols). Also,
strace -r would probably produce some useful information.
I will search the bug reports. Maybe packaging 3.10.2 might already
help (it's a minor release and minor effort to do). We are linking new
GNOME components, like gsd, against a few older ones - but I don't
think that this caused the problem here.
Regards,
    Matthias

-- 
Debian Developer | Freedesktop-Developer
I welcome VSRE emails. See http://vsre.info/


More information about the Tanglu-devel mailing list