two build problems with the packaging tutorial.

ROELOF WOBBEN r.wobben at home.nl
Tue Jan 28 07:37:06 EST 2014


 Hello, 

To learn packaging I try to follow the sid packaging tutorial. 

I ran into two problems. 

When I do debuild I see this output : 

 dpkg-buildpackage -rfakeroot -D -us -uc
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: source package grep
dpkg-buildpackage: source version 2.15-2
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by Santiago Ruano Rincón <santiago at debian.org>
 dpkg-source --before-build grep-2.15
dpkg-buildpackage: host architecture amd64
dpkg-source: info: using options from grep-2.15/debian/source/options: --compression=bzip2 --compression-level=9
 fakeroot debian/rules clean
dh_testdir
dh_autoreconf_clean
dh_testroot
rm -f build-stamp 
[ ! -f Makefile ] || /usr/bin/make distclean
make[1]: Map '/home/roelof/grep-2.15' wordt binnengegaan
 cd . && /bin/bash /home/roelof/grep-2.15/build-aux/missing automake-1.14 --gnu
configure.ac:79: error: required file 'build-aux/config.sub' not found
configure.ac:79: 'automake --add-missing' can install 'config.sub'
Makefile.am: error: required file './INSTALL' not found
Makefile.am: 'automake --add-missing' can install 'INSTALL'
doc/Makefile.am:19: error: required file 'build-aux/texinfo.tex' not found
doc/Makefile.am:19: 'automake --add-missing' can install 'texinfo.tex'
gnulib-tests/Makefile.am: error: required file 'build-aux/depcomp' not found
gnulib-tests/Makefile.am: 'automake --add-missing' can install 'depcomp'
make[1]: *** [Makefile.in] Fout 1
make[1]: Map '/home/roelof/grep-2.15' wordt verlaten
make: *** [clean] Fout 2
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2
debuild: fatal error at line 1364:
dpkg-buildpackage -rfakeroot -D -us -uc failed


And when I do pbuilder create I see this error : 

W: /root/.pbuilderrc does not exist
I: Distribution is sid.
I: Current time: Tue Jan 28 13:35:52 CET 2014
I: pbuilder-time-stamp: 1390912552
I: Building the build environment
I: running debootstrap
/usr/sbin/debootstrap
I: Retrieving Release 
E: Failed getting release file http://archive.tanglu.org/tanglu/dists/sid/Release
E: debootstrap failed
W: Aborting with an error
I: cleaning the build env 
I: removing directory /var/cache/pbuilder/build//20227 and its subdirectories


Anyone a idea how to solve both so I can go on learning packaging.

Roelof
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tanglu.org/pipermail/tanglu-devel/attachments/20140128/d915d399/attachment.html>


More information about the Tanglu-devel mailing list